Un bug la ultimul update de la W3 Total Cache

Astăzi, minunatul plugin de cache despre care am scris aici, a venit cu un update foarte interesant (găsiţi feature-uri aici dacă vă uitaţi la versiunea 0.9.2).

Printre toate lucrurile frumoase cu care vine, are un bug. Unul mic, aproape nesemnificativ, dar dacă nu ştiţi să-l dezactivaţi, vă treziţi că blogul se vede ca şi cum n-ar avea style.css şi nu ştiţi de unde vine toată treaba.

Puteţi face update-ul fără probleme, am să vă explic mai jos cum să scăpaţi de bug. Se pare că e o problemă la partea de Minify, pentru că nu reuşeşte să combine ca lumea fişierele .css şi .js. Mie îmi citea informaţii dintr-un fişier .css care nu exista. Credeam că-s probleme la permisiunile fişierelor, dar şi după ce i-am oferit toate permisiunile, tot aşa făcea. Am citit mai târziu că nu sunt singurul care a avut problema asta, deci e bug, nu e de la serverul meu.

Aşadar, dacă pagina voastră nu mai arată ca lumea după ce faceţi update-ul pentru W3 Total Cache, din panoul de administrare din stânga, duceţi-vă la Performance » General Settings şi căutaţi căsuţa Minify. Ca să nu existe probleme, ea ar trebui să arate aşa:
Bug W3 Total Cache

După cum vedeţi, funcţia Minify este bifată, dar este setată pe „Manual”. Dacă este bifat „Auto”, apar probleme. Totodată, problemele dispar şi dacă debifaţi căsuţa „Enable”.

Oricum, fără Minify nu moare blogul vostru, oricât de mult aţi ţine la viteza sa de încărcare. Iar băieţii de la W3Edge nu ne vor ţine aşa o veşnicie. Zilele următoare s-ar putea să apară alt update care să repare acest bug. Am scris articolul în cazul în care nu ştiţi să vă reparaţi blogul după ce-aţi făcut update.

P.S.: Mulţumesc @RalucaEnache şi @AlexGheorghiţan! Dacă nu-mi spuneaţi voi că blogul meu se vede anapoda, nu-mi dădeam seama de acest bug (aveam bifată chestia aia cum că administratorii n-ar trebui să beneficieze de minify din partea W3 Total Cache, deci mie totul mi se vedea normal).

Lasă un comentariu

12 comentarii

  • Florin 11 Mai 2011, ora 14:06

    Eu nu am avut aceasta problema, dar chiar acum am facut un update care rezolva acest bug :)

  • Zoly 11 Mai 2011, ora 14:18

    Tu chiar esti pasionat de astea :) mie mi se pare total neinteresant:D

    • Florea Cristian 11 Mai 2011, ora 15:52

      e neinteresant sa faci ce vrei cu blogul tau? :D

      • Zoly 11 Mai 2011, ora 15:53

        Daca nu ma pricep este neinteresant :))

      • Florea Cristian 11 Mai 2011, ora 15:54

        :)) nimeni nu s-a nascut invatat. daca te pasioneaza, poti invata. daca nu simti nicio atractie, nu-i nicio problema :D

  • Myky 11 Mai 2011, ora 15:36

    Am observat si eu problema ieri , aici la tine. Am crezut ca te ocupi de modificari si isi revine…

    • Florea Cristian 11 Mai 2011, ora 15:52

      nu, asta era problema. bine ca mi s-a atras atentia la timp si am remediat repede

  • OMUL SIMPLU 11 Mai 2011, ora 16:26

    am vazut si eu bugul asta am crezut ca si Myky ca umblii tu pe acolo de asta nu ti-am spus. Am facut si eu update-ul si nu am avut probleme se pare ca nu la toti depinde de tema.

    • Florea Cristian 11 Mai 2011, ora 19:48

      de tema, sau de alte pluginuri instalate. cine stie? :-??

      oricum, daca ai facut backup azi, deja bugul a fost reparat :D

  • Alexandru George 4 Ian 2013, ora 22:14

    Eu am instalt pluginul si nu am probleme, insa nu vad nici-o diferenta .

    • Cristian Florea 5 Ian 2013, ora 13:46

      Tu poate nu, dar serverul tău da. Se consumă mai puţine resurse aşa.